Bij Incremental.SalesOrdersV2Incremental treed herhaaldelijk foutcode itgeneor328 op:
itgeneor328
Un filtre obligatoire est manquant.
Contactez le support Invantive.
Ce point de terminaison a un filtrage obligatoire appliqué.
Une requête GET pour ce point de terminaison doit avoir un paramètre $filter avec l’un des champs suivants dans l’URL : Timestamp.
Dans d’autres rapports, cette table est également présente ; ils ont été mis à jour plus tôt cette nuit sans problèmes.
Sinds 6 augustus omstreeks 02:12 UTC treedt op veel Exact Online-omgevingen de volgende foutmelding op:
itgeneor328
Een verplicht filter ontbreekt.
The remote server returned an error:
(400) Bad Request.
Neem contact op met Invantive Support:
This endpoint has mandatory filtering applied.
A GET request for this endpoint must have a $filter parameter with one of the following fields in the url:Timestamp.
De foutmelding hangt niet samen met aanpassingen aan Invantive Cloud (uit stabiliteitsoverwegingen is er sprake van een zomerstop), maar waarschijnlijk een upgrade van Exact Online.
Het probleem lijkt alle Exact Online-omgevingen te raken, zowel on-premises als Invantive Cloud, Get My Report, Valuta Tools, App Online, Bridge Online als websites die zich baseren op Invantive-technologie en producten van partners.
Betrokken URLs, waarbij “123456” de divisiecode van een van uw Exact Online-administraties kan zijn:
Il n’existe actuellement aucune solution disponible. Une demande a été soumise à Exact Online pour escalader le problème et/ou annuler le changement perturbateur.
Pour les petites tables, il peut être possible de remplacer le *Incremental par la table en vrac correspondante ou les tables DDL beaucoup plus lentes. Cependant, cela peut augmenter le temps de chargement jusqu’à un facteur de 1 000 et le nombre d’appels API nécessaires à des centaines de milliers par jour.
Invantive Development travaille à voir si un correctif peut être créé. Le déploiement de celui-ci au sein d’Invantive Cloud se fera en premier. Cependant, le déploiement par les administrateurs des partenaires et des utilisateurs peut prendre beaucoup plus de temps car un saut de version parfois important est nécessaire, ce qui peut entraîner de nouveaux problèmes.
Impact
Cela concerne désormais plusieurs centaines d’organisations, et on s’attend à ce que ce nombre augmente si le cache incrémentiel doit être réinitialisé. Cela peut ne jamais se produire, mais peut également se produire dans certains environnements après seulement quelques heures.
L’utilisation d’une table auparavant non utilisée peut également générer ce message d’erreur, donc les nouveaux utilisateurs seront immédiatement bloqués lors de l’utilisation.
Mise à jour
Dès que plus d’informations seront disponibles, ce sujet sera complété.
Exact a indiqué qu’il allait revenir sur le changement impliqué dans la nuit du 6 au 7 août. À un moment ultérieur, cela sera réactivé, mais avec des précautions supplémentaires pour éviter une situation de panne à grande échelle.
Spécifiquement pour Invantive Cloud, il est prévu qu’une version soit mise en production au cours du 6 août, qui ne générera plus le message d’erreur. Pour les partenaires et les utilisateurs sur site, une nouvelle version sera également disponible, mais étant donné le nombre d’installations et la période de vacances, il est conseillé d’intégrer cela dans une mise à jour ultérieure, puisque la cause disparaîtra dans la nuit du 6 au 7 août.
Exact n’a apparemment pas ou pas complètement annulé la modification. Une mise à niveau d’Invantive Cloud a résolu la plupart des problèmes. Le problème persiste encore avec :
les installations sur site des versions antérieures à 24.0.0756
Invantive Cloud lors de l’accès direct aux tables sync*
Pour ces dernières, la solution de contournement recommandée est d’utiliser la table *Incremental correspondante. Une nouvelle version sera également disponible dans laquelle les tables Sync seront modifiées.
Merci ! Capture d’écran ci-dessous. Ajouter un filtre est une bonne solution de contournement ! Cela n’a pas d’autre impact à part être une solution de contournement pour les versions plus anciennes.
La suggestion d’utiliser le filtrage est un peu étrange étant donné la conception des API de synchronisation