Errore 503 Server Non Disponibile

Dalla scorsa notte stiamo ricevendo lo stesso errore durante l’aggiornamento dei dati:

Source.Error: OData: Richiesta fallita:
Il server remoto ha restituito un errore:
(503) Server non disponibile.
(Servizio non disponibile):
MashupValueException.
RootActivityId = 52fe90d7-9574-4c65-baa9-d42e7273c598.
Param1 = DataSource.Error:
OData: Richiesta fallita:
Il server remoto ha restituito un errore:
(503) Server non disponibile. (Servizio non disponibile):
MashupValueException
Request ID: a628c674-12fd-5d4b-ce80-8b09721a0a2b.

Informazioni complete

È possibile aggiungere uno screenshot (anonimizzato) dei dettagli della richiesta in Invantive Bridge Online Monitoring, come descritto in More insight with new Bridge Online Monitoring?

I dettagli possono essere trovati cliccando sulla richiesta di download che rappresenta il problema discusso in questo argomento.

La richiesta di download solitamente contiene un’istruzione SQL con il nome della tabella visibile.

Si prega di lasciare almeno i seguenti dati visibili da entrambe le colonne:

  • la barra del titolo con l’ID della richiesta,
  • il codice di stato, la dimensione della rete, il percorso e i tempi nella colonna di sinistra,
  • il codice di errore e il messaggio di errore in fondo alla colonna di sinistra,
  • l’intera colonna destra compresa l’istruzione SQL, il nome della tabella e i valori dei parametri.

Ad esempio:

Verifica del server e utente corretto

Verifica attentamente che stai accedendo al sito web di Bridge Online utilizzato anche da Power BI e con lo stesso nome utente. Vedrai solo le richieste dell’utente di Invantive Cloud con cui sei collegato al sito web.

Ci sono quattro server in uso:

  • bridge-online.cloud
  • app-online.cloud
  • bridge-online.invantive.com
  • app-online.invantive.com

Puoi vedere il server utilizzato nel tuo script o nel codice sorgente del rapporto.

Verifica della richiesta e dettagli corretti

Assicurati di selezionare la richiesta per visualizzare i dettagli. Nello screenshot deve essere visibile solo una singola richiesta.

Controlla anche attentamente che la richiesta abbia un percorso con odata4 o apps. Altre richieste sono in generale non rilevanti per questo scopo.

Messaggio di errore e suggerimenti via email

Inoltre, l’utente di Invantive Cloud che ha il messaggio di errore riceverà di solito sulla sua e-mail un messaggio con un errore e suggerimenti se c’è un messaggio di errore in Power BI, Power Query, Azure Data Factory, Qlik o Tableau.

Si consiglia di controllare la cartella spam dell’utente interessato per tali email inviate da support@invantive.com.

Si prega di aggiungere le informazioni sopra indicate, se disponibili. Se non è disponibile un monitoraggio a partire da quel momento, si prega di fornire tutte le informazioni rilevanti, come l’ora in cui è stata effettuata la richiesta, l’indirizzo IP e l’URL richiesto.

L’ora della richiesta era 11:07:03, indirizzo IP [redacted] e uno degli URL utilizzati nei flussi di dati è: ** [redacted]

A causa di un problema al server, occasionalmente si verifica un errore HTTP 503. Stiamo analizzando il problema.

La causa è stata individuata e si sta preparando una soluzione.

È stata implementata una correzione con il rilascio 26.0.180 su Bridge Online.