Snelstart Relaties itgenjuy020

Seit einigen Wochen erhalte ich eine Fehlermeldung beim Laden der Schnellstart-Relationstabelle (SnelStart.Handel.Relaties):

itgenjuy020
Systemfehler.

Im Power BI Service erhalte ich folgende Details zum Fehler:

DataSource.Error:
OData:
Ungültiges JSON.
Unerwartetes Ende der Eingabe wurde im JSON-Inhalt gefunden.
Nicht alle Objekt- und Arraybereiche wurden geschlossen.

Analyse.

Die zugrunde liegende Fehlermeldung lautet:

itgenjuy020
Das Feld ‘vestigingsAdres_land_id’ kann nicht in den Typ ‘Guid?’ konvertiert werden. (00000000-0000-0000-0000-000000000000)
itgenodr028
Der GUID-Wert der Spalte ‘vestigingsAdres_land_id’ von SnelStart.Handel.Relaties hat einen Standardwert.
Nullable: Wahr.
Kontaktieren Sie den Cloud-Platform-Anbieter, um die API zu korrigieren.

Das Feld vestigingsAdres_land_id ist ein optionaler Datentyp, enthält aber speziell in diesem Feld einen Standardwert. Dies weist möglicherweise auf einen Softwarefehler in SnelStart hin.

Wir werden uns mit dem SnelStart API-Support in Verbindung setzen, um zu fragen, ob dies in SnelStart adressiert wird oder ob eine Umschreibung von Invantive erforderlich ist, um das Problem zu umgehen.

Nach Rücksprache mit dem SnelStart API Support wurde festgestellt, dass SnelStart möglicherweise in einer zukünftigen Version einen Fix einführen wird und Invantive ab der Version 26.0.150 einen Workaround umsetzt.

Diese neue Version ist/ wird in der Produktion auf Invantive Cloud implementiert.

Für mehr Informationen siehe:

Ich habe gehört, dass eine Anpassung vorgenommen wurde, also habe ich das gerade getestet. Die Meldung ist anders, aber immer noch im gleichen Bereich. Das JSON-Format ist immer noch nicht korrekt;

DataSource.Error:
OData:
Ungültiges JSON.
Ein Komma-Zeichen ‘,’ wurde im Bereich ‘Array’ erwartet.
Alle zwei Elemente in einem Array und Objekteigenschaften müssen durch Kommas getrennt sein.

Hoffentlich könnt ihr bald diese Ergänzung in der vorgenommenen Anpassung umsetzen. Vielen Dank im Voraus für die Mühe!

Zusätzliche Informationen

Ist es möglich, einen (anonymisierten) Screenshot der Details der Anfrage in Invantive Bridge Online Monitoring hinzuzufügen, wie beschrieben unter Meer inzicht met nieuwe Online Monitoring?

Die Details finden Sie, indem Sie auf die Download-Anfrage klicken, die das Thema dieses Themas darstellt.

Die Download-Anfrage enthält normalerweise eine SQL-Anweisung, in der der Tabellenname sichtbar ist.

Bitte lassen Sie mindestens folgende Daten aus beiden Spalten sichtbar:

  • Die Titelleiste mit der Request-ID,
  • Der Statuscode, die Netzwerkgröße, der Pfad und die Zeiten in der linken Spalte,
  • Der Fehlercode und die Fehlermeldung ganz unten in der linken Spalte,
  • Die gesamte rechte Spalte einschließlich der SQL-Anweisung, Tabellenname und Parameterwerte.

Beispielsweise:

Überprüfen des richtigen Servers und Benutzers

Überprüfen Sie sorgfältig, dass Sie sich auf der Bridge Online-Website anmelden, die auch von Power BI verwendet wird, und mit demselben Benutzernamen. Sie sehen nur die Anfragen des Invantive Cloud-Nutzers, mit dem Sie sich auf der Website anmelden.

Es sind vier Server im Einsatz:

  • bridge-online.cloud
  • app-online.cloud
  • bridge-online.invantive.com
  • app-online.invantive.com

Der verwendete Server ist in Ihrem Skript oder Quellcode des Berichts ersichtlich.

Überprüfen der richtigen Anfrage und Details

Stellen Sie sicher, dass Sie die Anfrage zuerst auswählen, um die Details anzuzeigen. Es sollte nur eine Anfrage im Screenshot sichtbar sein.

Überprüfen Sie auch sorgfältig, ob die Anfrage einen Pfad mit odata4 oder apps hat. Anfragen mit anderen Pfaden sind im Allgemeinen für diesen Zweck nicht relevant.

Fehlermeldung und Tipps per E-Mail

Außerdem wird der Invantive Cloud-Nutzer, der die Fehlermeldung auf seiner E-Mail-Adresse erhalten hat, im Allgemeinen eine E-Mail mit einer Fehlermeldung und Tipps erhalten, wenn es eine Fehlermeldung in Power BI, Power Query, Azure Data Factory, Qlik oder Tableau gibt.

Es wird empfohlen, den Spam des betreffenden Nutzers auf solche E-Mails, die von support@invantive.com gesendet werden, zu überprüfen.

itgenjuy020
Das Feld ‘vestigingsAdres_land_id’ kann nicht als Typ ‘Guid?’ interpretiert werden.
Der GUID-Wert der Spalte ‘vestigingsAdres_land_id’ von SnelStart.Handel.Relaties hat einen Standardwert.
Nullable: True.
Wenden Sie sich an den Cloud-Plattform-Anbieter, um die API zu korrigieren.

Die neue Version 26.0.149 war noch nicht auf dem Invantive Bridge Online-Komponenten installiert. Dort lief noch die Version 26.0.148. Bitte versuchen Sie es erneut.

Bitte beachten Sie, dass bis zum 1. September 2026 nur für weitreichende Probleme neue Versionen auf Invantive Cloud in Produktion genommen werden, aufgrund der „frozen period“.

Direkt nach der vorherigen Mitteilung (telefonisch), dass eine Anpassung durchgeführt worden war, erhielt ich die Meldung, die ich am 29.06. in diesem Forum beschrieben habe. Am nächsten Tag war diese Meldung wieder wie zuvor. Jetzt gebt ihr an, dass dieser Release nicht erfolgt war.

Mein Verdacht ist folgender: Das Update war tatsächlich da, denn es gab einen anderen Fehler. Der Release war also unvollständig und wurde schnell zurückgenommen. Nun ist es erneut ausgerollt worden, und ich erhalte wieder diese Meldung:

DataSource.Error:
OData:
Ungültiges JSON.
Ein Komma-Zeichen ‘,’ wurde im Bereich ‘Array’ erwartet.
Alle zwei Elemente in einem Array und Eigenschaften eines Objekts müssen durch Kommas getrennt werden.

Inzwischen sind wir bereits seit über zwei Wochen down.

Der prozessuale Rat ist, nicht mehrere parallele Kommunikationskanäle zu eröffnen, sondern ausschließlich über die Foren zu eskalieren. Mehrere Kanäle wirken in der Praxis oft störend und qualitätsmindernd, so unangenehm es auch sein mag.

Für die aktuelle Meldung wird empfohlen, wie zuvor einen Screenshot der Anfrage hinzuzufügen.

Sollte es vorrangig sein, wird empfohlen, SnelStart die Datenkorruption beheben zu lassen.

Die parallele Kommunikation erfolgt über Snelstart. Sie versuchen, bei der Suche nach einer Lösung zu helfen.

Version 26.0.168 von Invantive Bridge Online

itgenjuy020
Das Feld ‘correspondentieAdres_land_id’ kann nicht als Typ ‘Guid?’ interpretiert werden.
Der GUID-Wert der Spalte ‘correspondentieAdres_land_id’ von SnelStart.Handel.Relaties hat einen Standardwert.
Nullable: True.
Kontaktieren Sie den Cloud-Plattform-Anbieter, um die API zu korrigieren.

Abfrage:

select t.*
from   SnelStart.Handel.Relaties@snr t

Ein Analyst wird sich diese Fehlermeldung ansehen.

Sollte es einen Zugang bei SnelStart geben, wird empfohlen, diesen zu bitten, den zugrunde liegenden Datenfehler zu beheben.

Die ursprüngliche Fehlermeldung betraf das Feld vestigingsAdres_land_id. Diese blockierte durch folgende Fehlermeldung nämlich das Feld correspondentieAdres_land_id.

Für correspondentieAdres_land_id wurde ein Workaround in die Programmierung aufgenommen. Dieser wird in der nächsten Version in Produktion genommen.

Danke für das Feedback. Hoffen wir, dass wir bald wieder starten können!

Gibt es einen Zeitplan, wann die nächste Version in Produktion geht? Seit dem 22. Juni haben wir keine aktuellen Dashboards mehr und das beginnt in Bezug auf den Monatsabschluss usw. problematisch zu werden.

Die letzte Version vor der Sommerpause wurde am Abend des 7. Juli 2026 in Produktion genommen. Die Änderung sollte darin enthalten sein.

Der Release wurde zurückgezogen aufgrund von Problemen in anderen Komponenten, die Auswirkungen auf eine größere Anzahl von Benutzern hatten. Es ist unklar, ob vor dem Ende der Sommerpause noch ein Release stattfinden wird.

Da die Auswirkungen begrenzt sind und die Ursache in SnelStart selbst liegt, wird dieser Punkt nicht als ausreichend kritisch betrachtet, um das Durchbrechen der gefrorenen Periode zu rechtfertigen.

Die Empfehlung ist, eine alternative (manuelle) Lösung zu wählen, wenn Sicherheit benötigt wird.

Ah, was für ein Pech! Wir konnten einmal erfolgreich aktualisieren, aber gehen jetzt wieder eine gewisse Zeit ohne aktuelle Daten ein. Sehr ärgerlich.
Könnt ihr konkret angeben, was bei anderen schiefgeht und wo ich das verfolgen kann?

Aufgrund der Dauer und Unsicherheit bezüglich unserer bezahlten Verbindung könnt ihr uns sicherlich weiterhelfen, eine Lösung zu finden:
Wir kennen dieses Feld nicht, und die vermutlich zugeordneten Länderfelder sind alle ausgefüllt. Sicher könnt ihr uns dann mitteilen, bei welchem(n) Datensatz/Daten es in unserem System Probleme gibt. Bitte auf “RelatieCode” oder ID übermitteln.

Dabei möchte ich euch auch auf Folgendes hinweisen:

Zu dieser Zeit wurde unsere Erneuerung gestoppt. Und im Release befinden sich die Problemfelder, auf die die Fehlermeldung hinweist.
Kann dieses Release dann zurückgenommen werden? Dann wäre uns, denke ich, auch geholfen.

Viele Grüße

Wir verstehen, dass dies Herausforderungen mit sich bringt, wofür wir uns entschuldigen. Das Problem, das uns gezwungen hat, die Veröffentlichung zurückzuziehen, betraf Dutzende von Kunden, sodass wir keine andere Wahl hatten, als zurückzuziehen. Es wird an einer Lösung für dieses Problem gearbeitet. Hoffentlich können wir bald eine angepasste Version herausbringen, die beide Probleme löst.

Es ist uns nicht ganz klar, wo die Ursache des Problems liegt. Sind die Daten in SnelStart fehlerhaft oder liegt es an der Verbindung mit Invantive? In den letzten Wochen waren verschiedene Personen mit der Problemanalyse beschäftigt, aber wir konnten es nicht eindeutig herausfinden. Daher ist auch eine schnelle und unsaubere Lösung schwer zu bestimmen. Könnt ihr klar beschreiben, was das Problem verursacht?

Die Ursache liegt in einem Fehler in den von SnelStart gelieferten Daten. Konkret hat das Feld vestigingsAdres_land_id einen ungültigen Wert: 00000000-0000-0000-0000-000000000000. Die Invantive-Software hat Schutzmechanismen für Datenqualität eingebaut, die verhindern, dass dieser Wert verwendet werden kann. Tatsächlich hätte das Feld leer sein müssen. Dies tritt bei einigen Beziehungen in SnelStart auf.

Das Problem könnte möglicherweise einfach von der Seite SnelStart gelöst werden, indem bei den betreffenden Beziehungen ein Land zu den Adressen zugeordnet oder das Feld in der SnelStart-Datenbank auf den Wert null gesetzt wird (dies wäre wahrscheinlich eine Maßnahme seitens SnelStart).

Der Grund, warum die angepasste Invantive-Version nicht implementiert werden kann, hängt mit einer anderen, hier nicht zusammenhängenden Störung zusammen, zu der wir in diesem Thema keine weitere Erklärung geben können.