Depuis quelques semaines, je reçois un message d’erreur lors du chargement de la table de démarrage rapide Relaties (SnelStart.Handel.Relaties) :
itgenjuy020
Erreur système.
Dans Power BI Service, je vois ces détails dans l’erreur :
DataSource.Error :
OData :
JSON invalide.
Une fin de saisie inattendue a été trouvée dans le contenu JSON.
Tous les objets et tableaux n’ont pas été correctement fermés.
itgenjuy020
Impossible de convertir le champ ‘vestigingsAdres_land_id’ en type ‘Guid?’. (00000000-0000-0000-0000-000000000000)
itgenodr028
La valeur GUID de la colonne ‘vestigingsAdres_land_id’ de SnelStart.Handel.Relaties a une valeur par défaut.
Nullable : Vrai.
Contactez le fournisseur de la plateforme cloud pour corriger l’API.
Le champ vestigingsAdres_land_id est de type optionnel, mais contient dans ce cas précis une valeur par défaut. Cela indique éventuellement un bug logiciel dans SnelStart.
Nous allons contacter le support API de SnelStart pour demander si cela sera adressé dans SnelStart ou si une réécriture est nécessaire de la part d’Invantive pour contourner le problème.
Après consultation avec le support API de SnelStart, il a été déterminé que SnelStart pourrait introduire un correctif dans une future version et qu’Invantive mettra en place un contournement à partir de la version 26.0.150.
Cette nouvelle version est/sera mise en production sur Invantive Cloud.
J’ai appris qu’une modification avait été faite, donc je viens de la tester. Le message est différent mais reste dans la même catégorie. Le format JSON n’est toujours pas correct ;
Erreur de source de données:
OData:
JSON invalide.
Un caractère virgule ‘,’ était attendu dans le contexte ‘Array’.
Chaque deux éléments dans un tableau et les propriétés d’un objet doivent être séparés par des virgules.
J’espère que vous pourrez bientôt effectuer cette modification dans l’ajustement effectué. Merci d’avance pour l’effort fourni !
Est-il possible d’ajouter une capture d’écran (anonymisée) des détails de la demande dans la surveillance en ligne d’Invantive Bridge comme décrit dans Meer inzicht met nieuwe Online Monitoring?
Vous trouverez les détails en cliquant sur la demande de téléchargement qui représente le sujet de ce sujet.
La demande de téléchargement contient généralement une instruction SQL où le nom de la table est visible.
Veuillez afficher au moins les données suivantes des deux colonnes :
la barre de titre avec l’ID de la demande,
le code d’état, la taille du réseau, le chemin et les heures dans la colonne de gauche,
le code d’erreur et le message d’erreur tout en bas de la colonne de gauche,
la colonne de droite entière, y compris l’instruction SQL, le nom de la table et les valeurs des paramètres.
Assurez-vous soigneusement que vous vous connectez sur le site Bridge Online qui est également utilisé depuis Power BI et avec le même nom d’utilisateur. Vous ne verrez que les demandes de l’utilisateur Invantive Cloud avec lequel vous vous connectez sur le site.
Quatre serveurs sont utilisés :
bridge-online.cloud
app-online.cloud
bridge-online.invantive.com
app-online.invantive.com
Vous verrez le serveur utilisé dans votre script ou le code source du rapport.
Vérifier la bonne demande et les détails
Assurez-vous de sélectionner d’abord la demande pour afficher les détails. Il ne doit y avoir qu’une seule demande visible dans la capture d’écran.
Vérifiez également soigneusement que la demande comporte un chemin avec odata4 ou apps. Les demandes avec d’autres chemins ne sont généralement pas pertinentes pour cet objectif.
Message d’erreur et conseils par e-mail
En outre, l’utilisateur Invantive Cloud qui a reçu le message d’erreur sur son adresse e-mail recevra souvent un e-mail avec un message d’erreur et des conseils en cas d’erreur dans Power BI, Power Query, Azure Data Factory, Qlik ou Tableau.
Il est conseillé de vérifier les spams de l’utilisateur concerné pour les e-mails envoyés à partir de support@invantive.com.
itgenjuy020
Le champ ‘vestigingsAdres_land_id’ ne peut pas être interprété comme un type ‘Guid?’.
La valeur GUID de la colonne ‘vestigingsAdres_land_id’ de SnelStart.Handel.Relaties a une valeur par défaut.
Nullable : True.
Contactez le fournisseur de la plateforme cloud pour corriger l’API.
La nouvelle version 26.0.149 n’était pas encore installée sur le composant Invantive Bridge Online. Celui-ci fonctionnait toujours avec la version 26.0.148. Veuillez essayer à nouveau.
Veuillez noter qu’à compter du 1er septembre 2026, seules les nouvelles versions résolvant des problèmes généralisés seront mises en production sur Invantive Cloud en raison de la période de gel.
Directement après l’annonce précédente (par téléphone) qu’un ajustement avait été effectué, j’ai reçu le message que j’ai décrit sur ce forum le 29/06. Le lendemain, ce message était revenu à son état antérieur. Maintenant, vous indiquez que cette mise à jour n’avait pas été faite.
Mon hypothèse est la suivante : la mise à jour a bien eu lieu, car elle a généré une autre erreur. Donc, la version était incomplète et a été rapidement annulée. Maintenant, elle a été à nouveau déployée et je reçois encore ce message :
DataSource.Error :
OData :
JSON invalide.
Un caractère virgule ‘,’ était attendu dans le contexte ‘Tableau’.
Chaque deux éléments d’un tableau et les propriétés d’un objet doivent être séparés par des virgules.
Nous sommes déjà en panne depuis plus de deux semaines.
Le conseil procédural consiste à ne pas ouvrir plusieurs canaux de communication parallèles, mais uniquement à escalader via les forums. En pratique, plusieurs canaux perturbent souvent et réduisent la qualité, aussi désagréable que cela puisse être.
Pour la notification actuelle, il est conseillé d’ajouter une capture d’écran de la demande comme auparavant.
Si une priorité s’impose, il est conseillé de laisser SnelStart résoudre la corruption de données.
itgenjuy020
Le champ ‘correspondentieAdres_land_id’ ne peut pas être interprété comme un type ‘Guid?’.
La valeur GUID de la colonne ‘correspondentieAdres_land_id’ de SnelStart.Handel.Relaties a une valeur par défaut.
Nullable : Vrai.
Contactez le fournisseur de la plateforme cloud pour corriger l’API.
Le message d’erreur initial concernait le champ vestigingsAdres_land_id. Celui-ci était bloqué par l’erreur suivante, à savoir le champ correspondentieAdres_land_id.
Pour correspondentieAdres_land_id, une solution de contournement a été intégrée dans le logiciel. Celle-ci sera mise en production dans la prochaine version.
Y a-t-il une perspective sur le moment où la prochaine version sera mise en production ? Depuis le 22 juin, nous n’avons plus de tableaux de bord à jour et cela commence à devenir critique en raison de la clôture mensuelle, etc.
La version a été retirée en raison de problèmes dans d’autres composants affectant un plus grand nombre d’utilisateurs. On ne sait pas s’il y aura une nouvelle version avant la fin de la pause estivale.
Étant donné que l’impact est limité et que la cause réside dans SnelStart lui-même, ce point n’est pas considéré comme suffisamment critique pour justifier la rupture de la période gelée.
Il est conseillé de choisir une solution alternative (manuelle) si une certitude est nécessaire.
Ah zut alors ! Nous avons réussi à mettre à jour une seule fois, mais nous voilà repartis pour une période sans données actuelles. Très frustrant.
Pouvez-vous indiquer concrètement ce qui ne va pas chez les autres et où je peux suivre cela ?
En raison de la durée et de l’incertitude concernant notre liaison payante, vous pouvez certainement nous aider à trouver une solution :
Nous ne connaissons pas ce champ, et les champs associés supposés sont tous remplis. Sans aucun doute, vous pouvez nous indiquer sur quel(s) enregistrement(s) cela pose problème dans notre administration. Veuillez fournir le code relationnel ou l’identifiant.
Je souhaite également attirer votre attention sur ceci :
C’est à peu près à cette période que notre mise à jour s’est arrêtée. Et dans la version, il y a les champs problématiques qui sont visés par le message d’erreur.
Cette version peut-elle être annulée ? Cela nous aiderait, je pense.
Nous comprenons que cela pose des défis, et nous nous en excusons. Le problème qui nous a poussés à annuler la version a affecté des dizaines de clients, ce qui nous a contraints à faire marche arrière. Une solution à ce problème est en cours de développement. Nous espérons pouvoir déployer bientôt une version adaptée qui résoudra les deux problèmes.
Il n’est pas tout à fait clair pour nous où se situe la cause du problème. Les données dans SnelStart sont-elles incorrectes ou est-ce dû à l’intégration d’Invantive ? Ces dernières semaines, plusieurs personnes ont travaillé sur l’analyse du problème, mais nous n’arrivons pas à le clarifier. Par conséquent, il est également difficile de déterminer une solution rapide et provisoire. Pourriez-vous décrire clairement ce qui cause le problème ?
La cause réside dans une erreur dans les données fournies par SnelStart. Plus précisément, le champ vestigingsAdres_land_id a une valeur invalide : 00000000-0000-0000-0000-000000000000. Le logiciel Invantive a incorporé des sécurités pour la qualité des données et cela empêche l’utilisation de cette valeur. En fait, le champ aurait dû être vide. Cela se produit dans plusieurs relations dans SnelStart.
Le problème pourrait peut-être être résolu simplement du côté de SnelStart en associant un pays aux adresses des relations concernées, ou en attribuant la valeur null au champ dans la base de données SnelStart (ce qui est probablement une action du côté de SnelStart).
La raison pour laquelle la version modifiée d’Invantive ne peut pas être mise en œuvre est liée à un autre problème, non lié ici, sur lequel nous ne pouvons pas donner plus d’explications dans ce sujet.