Eliminatie administratie wordt niet geladen in PowerBI

In Invantive zien Marco en ik de eliminatie administratie voor een klant wel staan.
Echter, als het PowerBI Dashboard wordt gerefresht staat die er niet tussen als administratie.
Deze administratie is later toegevoegd.

Hoor graag hoe we dit kunnen verhelpen.

Waar is die Exact Online administratie zichtbaar in Invantive?

Wanneer en hoe is de administratie toegevoegd?

Het gaat om een Twinfield administratie. In Invantive zien we de administratie wel staan, deze administratie is later in Twinfield toegevoegd. Wanneer we de data in PowerBI willen laden komt deze administratie als enige niet naar boven.

Waar is die Twinfield administratie zichtbaar in Invantive?

Een administratie die toegevoegd is aan de rechten van de gebruiker hoort na enige tijd zichtbaar te worden. De vertraging is afhankelijk van de instellingen van de gebruikte caches; zie ook Differentieer OData4 cachegedrag met Power BI.

Als vanuit het scherm met de databasedefinitie de “SQL Editor” geopend wordt, is de administratie dan zichtbaar bij het uitvoeren van:

select code
,      name
from   offices@tfd

Is de administratie zichtbaar bij het uitvoeren van:

select code
,      name
from   systempartitions@datadictionary
where  provider_name='Twinfield'

Welke SQL statements staan bij de databasedefinitie onder “Startup SQL”, en in het bijzonder welk “use” statement?

Verder is het advies om het Power BI rapport te controleren op de aanwezigheid van filters bij het ophalen van de gegevens.

In welke tabel ontbreekt de administratie?