Itgenoda093: Er ontbreekt minimaal één divisie in uw filter op 'ExactOnlineREST.FinancialTransaction.TransactionLinesBulk'. Ontbrekende divisies: xxxxxxx

Can only retrieve data for the first division of a client.

Example of query:

SELECT AmountDC
,      Date
,      Description
,      FinancialPeriod
,      FinancialYear
,      GLAccount
,      GLAccountCode
,      GLAccountDescription
,      Type
FROM   ExactOnlineREST.FinancialTransaction.TransactionLinesBulk 
Where  FinancialYear = x 
AND    Division = y

We’re connecting through an ODBC connector for OData connections. Due to limitations when it comes to OData connections in our BI-tooling. It worked fine until we went from the free trial to production.

Hi Bart,

It seems the value you are providing for Division (y) can’t be found in the list of available divisions (called “partitions” in Invantive software).

You can check the list of divisions (in the table ExactOnlineREST..SystemDivisions and systempartitions@datadictionary) and check whether the division is visible there.

If not, the user doesn’t have access permission on the division (for a possible reason see Itgeneor228 / itgenoda060: Forbidden - User division is not within division scope - #2 door guido.leenders), or the division doesn’t exist.

Already checked the forum article you’re suggesting and the division is visible in the SystemDivisions table. Also, keep in mind everything worked fine until something changed license-wise.

Please try again.

The On Startup SQL of the two databases were changed in relationship to the pending license change. The default Exact Online company of the associated user would be used. The behaviour has been changed to include all companies.

SystemDivisions shows all available divisions, both selected as not yet selected. In SystemPartitions@DataDictionary you can check whether a division (“partition”) is selected by filtering on the is_selected column.

Does it work now?

That seems to have solved it. However, now the datacontainers keep asking to renew authorisation (since I changed the authorisation to Client ID/Secret instead of invantive cloud). Could that be some setting on your side as well?

Please when requested renew authorization once per data container. When it keeps reporting an error, please let us know the exact time and we will analyze it.

Problem persists, it keeps throwing ‘itgenscr652’. I can fix it by renewing authorisation, but that’ll only work once.

That is some kind of problem. Our team will look into it; a limited subset of the registrations seems to have frequent issues leading to the itgenscr562. We apologize for this. While our team is looking for a cause that Invantive can solve, please configure auto-recovery of Exact Online refresh tokens as described on Auto-recovery van Exact Online refresh tokens voor datacontainers (Dutch).