Error itgenstp015 when loading Teamleader into Azure Data Factory


I’m trying to recreate mentioned situation on How to filter data from OData query on Azure Data Factory? - #5 to add filtering to an OData call in Azure Data Factory. I’m trying to read from TeamLeader.V2.Deals but only those records that are created or updated after a certain point in time which will be a parameters determined in a previous step in a pipeline in ADF.

When using above configuration (which has changed a lot since last year) I keep getting the following error:

ErrorCode=ODataRequestNotSucceeded,'Type=Microsoft.DataTransfer.Common.Shared.HybridDeliveryException,Message=Requesting response from path Teamleader.V2.Deals@tlr and query $filter=created_at geq '2021-09-01' failed with status code InternalServerError and message {"error":{"code":"itgenstp015","message":"Syntax error at position 14 in \u0027created_at geq \u00272021-09-01\u0027\u0027. (itgenstp015, ab69e4c2-7e36-40e7-98e1-d7ff710fd0d0)","target":null,"details":[{"code":"ab69e4c2-7e36-40e7-98e1-d7ff710fd0d0","target":null,"message":"Unique ID"}],"innererror":null}}.,Source=Microsoft.DataTransfer.Runtime.ODataConnector,'

I’ve tried both with single and double quotes, but both give the same error.

Am I missing something that needs to be configured in ADF? Or is there something else that I’m missing?

Thanks in advance,
Jeroen IJ.

Most likely the filter is wrong:

Syntax error at position 14 in \u0027created_at geq \u00272021-09-01\u0027

Unicode-escaped characters are not displayed correctly, but after rewriting it says:

Syntax error at position 14 in 'created_at geq ‘2021-09-01’

Position 14 is the q:

created_at geq '2021-09-01

The OData4 specification explains it in more detail at OData Version 4.01. Part 2: URL Conventions, but it probably means the greater than or equal operator: OData Version 4.01. Part 2: URL Conventions

The greater than or equal operator is called ge.