Fout itgeneuy106: De ingevoerde verificatiecode is onjuist of verlopen

Bij het downloaden van data met Data Hub uit Exact Online treedt de in het onderwerp genoemde fout op (deze fout trad op sinds 5 september, al voor de problemen met itgenobr113):

itgeneuy106
De ingevoerde verificatiecode is onjuist of verlopen

De download is gestart nadat ik vanochtend eerst de update heb geïnstalleerd, die beschikbaar is gesteld vanuit topic " Various Exact Online log on procedures broken (itgenobr113)"
Hieronder 2 stukken uit de logfile.

Het eerste stuk laat het tijdstip van aanmelden zien; het tweede stuk laat het tijdstip van de foutmelding zien.
In de tijd tussen de twee citaten uit de logfile zijn er wel degelijk instructies probleemloos uitgevoerd.

2022-09-09 07:37:53.645 Information itgendhb203: Aanmelden
2022-09-09 07:38:02.394 Information itgencun014: Invantive Data Hub (22.0.341-PROD+3569)
2022-09-09 07:38:02.394 Information itgencun015: (C) Copyright 2004-2022 Invantive Software BV, the Netherlands. All rights reserved.
2022-09-09 07:38:02.516 Information itgendhb204: Verbonden! Verbinden duurde 8.871 ms.
2022-09-09 07:38:03.201 Information itgendhb122: local remark *** Alle administraties ***

Tweede citaat:

2022-09-09 07:47:19.496 Information itgendhb044: SQL-statement uitvoeren:
select count() from TransactionLinesIncremental@eol
2022-09-09 07:48:36.873 Warning itgendhb173: Context: select count(
) from TransactionLinesIncremental@eol
2022-09-09 07:48:36.924 Error itgencun016: Fout itgeneuy106: De ingevoerde verificatiecode is onjuist of verlopen. Probeer het nog een keer. U kunt het nog 9 keer proberen. Daarna wordt uw account tijdelijk (5 minuten) geblokkeerd.

From my own experience, after I upgraded to 22.0.341, it worked this morning a few times :
I relaunched my scripts, they connect/calls Exact Online four times. Three of them worked, the last one not.

Now I get this error with QueryToool, but not all the time

The verification code you entred is incorrect or has expired.
Please try again.
You have 9 attempts left before your account is temporarily blocked for 5 minutes.
Why doesn’t my code work?
The verification code you entred is incorrect or has expired.
Please try again.
You have 9 attempts left before your account is temporarily blocked for 5 minutes.
Why doesn’t my code work?

[Note that the same error is given twice]

The workaround I use at this moment in steps:

  1. Enter manualy the 2-step-code from the Authenticator on your smartphone that belongs to the Exact Online account that is used for downloading in the Query Tool.
  2. Set a timer or wait for 10 minutes.
  3. Repeat from step 1. until your data is downloaded.

Wait again for fast publication of a new fix from Invantive :slight_smile:

Well, I did the same.

Once I manually entered the code from my Authenticator app, then I closed Query Tool and reopened again, then the automated implicit grant flow worked again.

Not sure if the manual entry corrected something or Exact is doing some A/B testing.

I hope that the automatic repair works for me too.
The last code I entered was 14 minutes ago.

I just saw a renewal in the Query Tool of authentication full automatic in progress, this is hopeful.

This error seems related to some new infrastructure on side of Exact Online. Subscribe to the following incident in order to be updated about this issue:

We have found that the issue is consistently reproducible without Invantive software.

Steps to reproduce:

The following error message is shown, even before a MFA-code is requested:

image

The verification code you entered is incorrect or has expired.
Please try again.
You have 10 attempts left before your account is temporarily blocked for 5 minutes.
Why doesn’t my code work?

The number “10” in the error clearly indicates no invalid MFA password has been provided yet, since all 10 attempts are still available.

The number “10” also clearly indicates that there is a (new) bug in the Exact Online. Our logging indicates that the problem occurs frequently, but not on all log on efforts.

The first occurrence was:

2022-09-05 00:18:29 UTC (West Europe: September 5, 2:18 in the morning)

The changes on the Exact Online log on leading to itgenobr113 errors do not have the same cause, although they are probably related. The itgenobr113 started September 7. It seems various changes are taken into production over time.

I just found out, that the Exact Online log on dialog screen pops-up completely at random for me.

That is correct. It seems that one out of approximately 10 log ons now fails. For users controlling the database connection through an interactive program such as Invantive Query Tool or Invantive Control for Excel, they just enter the verification code in the Microsoft Edge-control. For non-interactive use, the job fails.

The issue is constrained to interactive on-premises products and especially harms production use of Invantive Data Hub and Invantive Data Replicator, depending on the set up. There are no issues on Invantive Cloud.

Currently we are working on a workaround for the Exact Online bug to retry the log on to Exact Online under these specific conditions. We are assuming that with one out of 10 tries failing and no relationship between the log ons, trying multiple times reduces the chances of connection problems considerably.

We are also hoping that Exact Online will fix the bug, but given the impact on large production sites and sometimes slow corrections we are working on the workaround. There are no foreseen challenges that hinder the creation of a viable workaround; it is just a matter of time.

For now, please repeatedly run your non-interactive jobs until they succeed. For instance, you could increase the frequency after checking the application logic.

In Belgium, the log on form again seems to be back to the original format this morning.

Exact Online development is now looking at the issue (ticket #03694454). The Exact Online log on problems with MFA verification code still occur randomly across a wide range of servers, platforms, Windows versions and browsers. Some users report a high frequency of occurring, whereas others see it once so often.

To gather more analytical information, please install the latest release from https://releasenotes.invantive.com.

Recommendation remains for Data Hub users to re-run their jobs and/or run it interactively using the Invantive Query Tool.

Ook bij gebruik van browserauthenticatie treedt deze melding op. Het probleem staat volledig los van de Invantive-producten, zowel on-premises als online.

Zojuist de beide versies Data Hub en Query tool 22.0.346.msi geïnstalleerd

vanochtend en de afgelopen dagen vastgesteld dat het probleem niet meer voor is gekomen.