Invantive word add-in Import and Export Issue

I am having issues utilizing Invantive Composition for Word add-in for certain users. There is no error thrown while completing the setup or utilization but buttons which we have previously utilized Import and Export are disabled for new user installs.

Installation process has been same for the last 4-5 years so that should not be the problem. I have tried multiple re-installs with no change.

That being said I was able to partially get a button enabled when I switched to Dummy-database.

Need help in finding possible solutions. We have tried to utilize latest add-in version with same result.

Software : Invantive Composition for Word add-in
Version : 20.0.141

The problem also occurs on the latest version. Let’s focus on that since the version mentioned has been out-of-support for years.

Please answer these questions using any 22.0 release from Word add-ins to connect with cloud data sources and databases, 180 days free.

Can you please add a reply with a picture of what is displayed “Import and Export are disabled”? Are these buttons or some other functionality?

What Microsoft Word version are you using?

Is it Microsoft Word 32-bit or 64-bit?

Can you enable trace before installation and send all collected trace files as a ZIP-file then to tracefiles@invantive.com with a reference to this URL?

The steps to enable trace are described on Provide Support with Data Hub and other on-premises products.

Here are the screenshots of errors I am getting.

Let me work on trace for the install.

Microsoft Version details: Microsoft Word 2019 MSO (16.0.10389.20033) 64-bit
image

image
image

Loading the Invantive.Word.Starter.vsto fails:

Name:
From: file:///c:/Program Files (x86)/Invantive Software BV/Invantive Composition for Word/starter/Invantive.Word.Starter.vsto
System.TimeoutException
The deployment manifest could not be downloaded because a connection to the network could not be established.
Ensure that you can connect to the network, and try again.

Can you add a reply with the contents of the file c:\Program Files (x86)\Invantive Software BV\Invantive Composition for Word/starter\Invantive.Word.Starter.vsto?

A time-out is reported (see “System.TimeoutException” in error).

Please also try in Microsoft Internet Explorer (which is integrated in the operating system) to disable the proxy and try again.

Please also repair the Microsoft Word installation from Programs & Settings. Then reboot and try again.

Please clear the Microsoft ClickOnce cache as illustrated on deployment - Clear the .NET-downloaded application cache without Mage? - Stack Overflow. Then reboot and try again.

Please also validate whether the installation works fine when the PC is not connected to the LAN and through some firewall and proxy to the Internet, but instead directly to the Internet (see ClickOnce Timeout Error).

Below are the contents of c:\Program Files (x86)\Invantive Software BV\Invantive Composition for Word/starter\Invantive.Word.Starter.vsto:

<?xml version="1.0" encoding="utf-8"?>
<asmv1:assembly xsi:schemaLocation="urn:schemas-microsoft-com:asm.v1 assembly.adaptive.xsd" manifestVersion="1.0" xmlns:asmv1="urn:schemas-microsoft-com:asm.v1" xmlns="urn:schemas-microsoft-com:asm.v2" xmlns:asmv2="urn:schemas-microsoft-com:asm.v2" xmlns:xrml="urn:mpeg:mpeg21:2003:01-REL-R-NS" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3" xmlns:dsig="http://www.w3.org/2000/09/xmldsig#" xmlns:co.v1="urn:schemas-microsoft-com:clickonce.v1" xmlns:co.v2="urn:schemas-microsoft-com:clickonce.v2">
  <assemblyIdentity name="Invantive.Word.Starter.vsto" version="1.0.0.0" publicKeyToken="118227abd7d25cc3" language="neutral" processorArchitecture="msil" xmlns="urn:schemas-microsoft-com:asm.v1" />
  <description asmv2:publisher="HP Inc." asmv2:product="Invantive.Word.Starter" xmlns="urn:schemas-microsoft-com:asm.v1" />
  <deployment install="false" />
  <compatibleFrameworks xmlns="urn:schemas-microsoft-com:clickonce.v2">
    <framework targetVersion="4.7.2" profile="Full" supportedRuntime="4.0.30319" />
  </compatibleFrameworks>
  <dependency>
    <dependentAssembly dependencyType="install" codebase="Invantive.Word.Starter.dll.manifest" size="13524">
      <assemblyIdentity name="Invantive.Word.Starter.dll" version="1.0.0.0" publicKeyToken="118227abd7d25cc3" language="neutral" processorArchitecture="msil" type="win32" />
      <hash>
        <dsig:Transforms>
          <dsig:Transform Algorithm="urn:schemas-microsoft-com:HashTransforms.Identity" />
        </dsig:Transforms>
        <dsig:DigestMethod Algorithm="http://www.w3.org/2000/09/xmldsig#sha256" />
        <dsig:DigestValue>xvFgOluqpM3bPCdby78zAOLrlaUUHRYrpxJMzFOqX14=</dsig:DigestValue>
      </hash>
    </dependentAssembly>
  </dependency>
<publisherIdentity name="CN=WS212\gle3" issuerKeyHash="4c0690eba54291a076f859d67948f6b0b9ea3232" /><Signature Id="StrongNameSignature" xmlns="http://www.w3.org/2000/09/xmldsig#"><SignedInfo><CanonicalizationMethod Algorithm="http://www.w3.org/2001/10/xml-exc-c14n#" /><SignatureMethod Algorithm="http://www.w3.org/2000/09/xmldsig#rsa-sha256" /><Reference URI=""><Transforms><Transform Algorithm="http://www.w3.org/2000/09/xmldsig#enveloped-signature" /><Transform Algorithm="http://www.w3.org/2001/10/xml-exc-c14n#" /></Transforms><DigestMethod Algorithm="http://www.w3.org/2000/09/xmldsig#sha256" /><DigestValue>ZFDmHINFoLB1UHoPaAOnkHgHdhxuuEp6jUNEi5tpDr0=</DigestValue></Reference></SignedInfo><SignatureValue>LptbLoIQiK90JDpnrZNJwJ9Yodj2HBuXy6ToJR3AGtsTKtA3Loo1gcJoOBWZedajhn/rYF7M42XYUa1QZGBk7tRiluwVb7oVjfgP1snz1O9NSit3hWskzBZsf1FXk21LxRWl7fR4wp4jut+51Y7Bzrzg2d6/OEVUG2sqxSTxwrw=</SignatureValue><KeyInfo Id="StrongNameKeyInfo"><KeyValue><RSAKeyValue><Modulus>uZr43Y51BiuhM5pcdZ9Q0olna+YbmeD+L1kNZ3w6D+b/NLk0XIEnEFs4zRLkxZR+JklHz+AKN7vMdCy/SNb7ySzArTqRuo777EMOoTwAVM6uAXMlju86kcE0txEv4WoPhowVJMJ0NSOkqTj0oZVQ3CkCJghNB7TACGtvrNHBr3U=</Modulus><Exponent>AQAB</Exponent></RSAKeyValue></KeyValue><msrel:RelData xmlns:msrel="http://schemas.microsoft.com/windows/rel/2005/reldata"><r:license xmlns:r="urn:mpeg:mpeg21:2003:01-REL-R-NS" xmlns:as="http://schemas.microsoft.com/windows/pki/2005/Authenticode"><r:grant><as:ManifestInformation Hash="bd0e699b8b44438d7a4ab86e1c76077890a703680f7a5075b0a045831ce65064" Description="" Url=""><as:assemblyIdentity name="Invantive.Word.Starter.vsto" version="1.0.0.0" publicKeyToken="118227abd7d25cc3" language="neutral" processorArchitecture="msil" xmlns="urn:schemas-microsoft-com:asm.v1" /></as:ManifestInformation><as:SignedBy /><as:AuthenticodePublisher><as:X509SubjectName>CN=WS212\gle3</as:X509SubjectName></as:AuthenticodePublisher></r:grant><r:issuer><Signature Id="AuthenticodeSignature" xmlns="http://www.w3.org/2000/09/xmldsig#"><SignedInfo><CanonicalizationMethod Algorithm="http://www.w3.org/2001/10/xml-exc-c14n#" /><SignatureMethod Algorithm="http://www.w3.org/2000/09/xmldsig#rsa-sha256" /><Reference URI=""><Transforms><Transform Algorithm="http://www.w3.org/2000/09/xmldsig#enveloped-signature" /><Transform Algorithm="http://www.w3.org/2001/10/xml-exc-c14n#" /></Transforms><DigestMethod Algorithm="http://www.w3.org/2000/09/xmldsig#sha256" /><DigestValue>Uvs5RLCrnkTp3EUWn4/l/+5khkKWDzDWN9TNKNgRsGw=</DigestValue></Reference></SignedInfo><SignatureValue>GpPu6yEPKjyqrkaVcjcwERdCSctGC0unXGIfd6epNXGOXJQvO89luZ/oZIlZNkrkrdZDMUCcGFjFQJMG34vDmpum4M4A046RwyqvPlV3yz+ibvBUNhJbPKsKXVzmSHUSRWFo4qU0G8h09/gik/JCWUh0Wm5tNqantJNkUP2DlVk=</SignatureValue><KeyInfo><KeyValue><RSAKeyValue><Modulus>uZr43Y51BiuhM5pcdZ9Q0olna+YbmeD+L1kNZ3w6D+b/NLk0XIEnEFs4zRLkxZR+JklHz+AKN7vMdCy/SNb7ySzArTqRuo777EMOoTwAVM6uAXMlju86kcE0txEv4WoPhowVJMJ0NSOkqTj0oZVQ3CkCJghNB7TACGtvrNHBr3U=</Modulus><Exponent>AQAB</Exponent></RSAKeyValue></KeyValue><X509Data><X509Certificate>MIIBwTCCASqgAwIBAgIQHPUzBBQrZrNJOrFsPZtyazANBgkqhkiG9w0BAQsFADAfMR0wGwYDVQQDHhQAVwBTADIAMQAyAFwAZwBsAGUAMzAeFw0xOTA0MTUxOTUyMjJaFw0yMDA0MTUwMTUyMjJaMB8xHTAbBgNVBAMeFABXAFMAMgAxADIAXABnAGwAZQAzMIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQC5mvjdjnUGK6Ezmlx1n1DSiWdr5huZ4P4vWQ1nfDoP5v80uTRcgScQWzjNEuTFlH4mSUfP4Ao3u8x0LL9I1vvJLMCtOpG6jvvsQw6hPABUzq4BcyWO7zqRwTS3ES/hag+GjBUkwnQ1I6SpOPShlVDcKQImCE0HtMAIa2+s0cGvdQIDAQABMA0GCSqGSIb3DQEBCwUAA4GBAA7n/ggT1awosNspQIHh3mymJOv5Ud9KtqvDbIErkNCHTuH15dmOWKkmjfhm54Xh3XTm8eo05AP8f2NkYlc1RbI9oQAk/VYDTSn83LsXcka06sx8aSyFk9+k6qZ1VDacXWvUU/kcdpunC+zG/P0wlheyk4X4hyhux8N64vnNvjcV</X509Certificate></X509Data></KeyInfo></Signature></r:issuer></r:license></msrel:RelData></KeyInfo></Signature></asmv1:assembly>

Let me try others steps provided above.

The VSTO seems OK without manual changes.

Please try the following from the original reply.

  • Please also try in Microsoft Internet Explorer (which is integrated in the operating system) to disable the proxy and try again.
  • Please also repair the Microsoft Word installation from Programs & Settings. Then reboot and try again.
  • Please clear the Microsoft ClickOnce cache as illustrated on deployment - Clear the .NET-downloaded application cache without Mage? - Stack Overflow. Then reboot and try again.
  • Please also validate whether the installation works fine when the PC is not connected to the LAN and through some firewall and proxy to the Internet, but instead directly to the Internet (see ClickOnce Timeout Error).

Yes, will work on the steps above and report back.

Below are completed based on above comments:

  1. Internet Explorer : This does not exist anymore with the organization. Not able to test this scenario.
  2. Word Repair- pending…
  3. ClickOnce Cache : Cleared and this brought about a new error, below details attached.
  4. Unfortunately not able to replicate this process as the add-in is within a VDI.

Error Details:

itgen_cannot_read_settings
at Invantive.Producer.Windows.Forms.UtilityBase.LoadDatabaseConnections(SerializableConnectionsList currentConnections)
at Invantive.Producer.Windows.Forms.UtilityBase.Initialize()

After updating the settings file below is the error

itgen_could_not_connect_reasons
at Invantive.Data.ConnectionManager.Open()
at Invantive.Producer.Windows.Forms.UtilityBase.OpenConnection(String username, String password)

Regarding 1: please try Microsoft Edge instead of Internet Explorer.
Regarding 2: please update once done and restarted.
Regarding 3: please add error codes, but from the looks it means the settings*.xml file can not be found. Due to installation issue, it seems that translations are not yet loaded.
Regarding 4: please try on another device or outside the network.